summaryrefslogtreecommitdiffstats
path: root/python/pickleshare/pickleshare.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pickleshare/pickleshare.SlackBuild')
-rw-r--r--python/pickleshare/pickleshare.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/pickleshare/pickleshare.SlackBuild b/python/pickleshare/pickleshare.SlackBuild
index a6c1061592..99a854da62 100644
--- a/python/pickleshare/pickleshare.SlackBuild
+++ b/python/pickleshare/pickleshare.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pickleshare
-# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pickleshare
VERSION=${VERSION:-0.7.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true