summaryrefslogtreecommitdiffstats
path: root/python/psutil/psutil.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/psutil/psutil.SlackBuild')
-rw-r--r--python/psutil/psutil.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/psutil/psutil.SlackBuild b/python/psutil/psutil.SlackBuild
index c37311562e..7432bbecb2 100644
--- a/python/psutil/psutil.SlackBuild
+++ b/python/psutil/psutil.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for psutil
-# Copyright 2012-2019 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=psutil
-VERSION=${VERSION:-5.6.3}
+VERSION=${VERSION:-5.6.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,8 +57,8 @@ find -L . \
python setup.py install --root=$PKG
-# Install python3 bindings for psutil. Default is no.
-if [ "${PYTHON3:-no}" == "yes" ]; then
+# Install python3 bindings for psutil.
+if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi