summaryrefslogtreecommitdiffstats
path: root/python/psutil/psutil.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/psutil/psutil.SlackBuild')
-rw-r--r--python/psutil/psutil.SlackBuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/python/psutil/psutil.SlackBuild b/python/psutil/psutil.SlackBuild
index 36b70a65d4..45881ed670 100644
--- a/python/psutil/psutil.SlackBuild
+++ b/python/psutil/psutil.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for psutil
-# Copyright 2012-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=psutil
-VERSION=${VERSION:-5.4.0}
+VERSION=${VERSION:-5.4.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -55,13 +55,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Remove shebangs
-find psutil -name "*\.py" | while read line; do
- sed -i.orig '/^#!/d' $line
- touch -r ${line}.orig $line
- rm ${line}.orig
-done
-
python setup.py install --root=$PKG
# Install python3 bindings for psutil. Default is no.