summaryrefslogtreecommitdiffstats
path: root/python/ptpython/ptpython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/ptpython/ptpython.SlackBuild')
-rw-r--r--python/ptpython/ptpython.SlackBuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/python/ptpython/ptpython.SlackBuild b/python/ptpython/ptpython.SlackBuild
index fa6d91177f..68537bfa85 100644
--- a/python/ptpython/ptpython.SlackBuild
+++ b/python/ptpython/ptpython.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ptpython
-# Copyright 2015-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2023 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ptpython
-VERSION=${VERSION:-2.0.6}
+VERSION=${VERSION:-3.0.25}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,7 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -90,7 +90,6 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE