summaryrefslogtreecommitdiffstats
path: root/python/pycrypto/pycrypto.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pycrypto/pycrypto.SlackBuild')
-rw-r--r--python/pycrypto/pycrypto.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/pycrypto/pycrypto.SlackBuild b/python/pycrypto/pycrypto.SlackBuild
index 6486933b51..34b8b3e4fd 100644
--- a/python/pycrypto/pycrypto.SlackBuild
+++ b/python/pycrypto/pycrypto.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pycrypto
-VERSION=2.6
+VERSION=${VERSION:-2.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -49,11 +49,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG