summaryrefslogtreecommitdiffstats
path: root/python/pyewmh/pyewmh.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyewmh/pyewmh.SlackBuild')
-rw-r--r--python/pyewmh/pyewmh.SlackBuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/python/pyewmh/pyewmh.SlackBuild b/python/pyewmh/pyewmh.SlackBuild
index 10c93a87cd..a2885d27e6 100644
--- a/python/pyewmh/pyewmh.SlackBuild
+++ b/python/pyewmh/pyewmh.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyewmh
-# Copyright 2016-2018 Hunter Sezen California, USA
+# Copyright 2016-2018, 2020 Hunter Sezen California, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pyewmh
VERSION=${VERSION:-0.1.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -55,15 +55,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if python3 -c 'import sys' 2>/dev/null; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a -- *.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install