summaryrefslogtreecommitdiffstats
path: root/python/pyflakes/pyflakes.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyflakes/pyflakes.SlackBuild')
-rw-r--r--python/pyflakes/pyflakes.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/pyflakes/pyflakes.SlackBuild b/python/pyflakes/pyflakes.SlackBuild
index c23a589577..07740d4781 100644
--- a/python/pyflakes/pyflakes.SlackBuild
+++ b/python/pyflakes/pyflakes.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pyflakes
VERSION=${VERSION:-0.7.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -51,11 +51,11 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --prefix=/usr/ --root=$PKG