summaryrefslogtreecommitdiffstats
path: root/python/pygame/pygame.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pygame/pygame.SlackBuild')
-rw-r--r--python/pygame/pygame.SlackBuild27
1 files changed, 21 insertions, 6 deletions
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index d2a6a8db78..cabc340de3 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -2,10 +2,11 @@
## Written by hollywoodb (hollywoodb@fastmail.fm)
# Modified by the SlackBuilds.org project
+# Modified by Bojan Popovic (bocke@slackware-srbija.org), 2014.
NAME=pygame
-VERSION=1.7.1
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-1.9.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -23,6 +24,18 @@ OUTPUT=${OUTPUT:-/tmp}
SRCVERSION=${VERSION}release
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+else
+ SLKCFLAGS="-O2"
+fi
+
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP || exit 1
@@ -36,16 +49,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Python programs use the CFLAGS specified used by python itself
-python -u config.py || exit 1
+# A patch borrowed from Arch community repo
+patch -p1 < $CWD/pygame-v4l.patch
+
+python -u config.py
+CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$NAME-$VERSION
-cp -a PKG-INFO WHATSNEW install.html readme.txt docs/* examples \
- $PKG/usr/doc/$NAME-$VERSION
+cp -a WHATSNEW README.txt $PKG/usr/doc/$NAME-$VERSION
cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
mkdir -p $PKG/install