summaryrefslogtreecommitdiffstats
path: root/python/pymongo/pymongo.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pymongo/pymongo.SlackBuild')
-rw-r--r--python/pymongo/pymongo.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/pymongo/pymongo.SlackBuild b/python/pymongo/pymongo.SlackBuild
index 9441c1762e..e1ceb0efe8 100644
--- a/python/pymongo/pymongo.SlackBuild
+++ b/python/pymongo/pymongo.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for pymongo
# Copyright 2013-2014 Christoph Willing, Australia
-# Copyright 2015-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pymongo
-VERSION=${VERSION:-3.5.1}
+VERSION=${VERSION:-3.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true