summaryrefslogtreecommitdiffstats
path: root/python/pyotp/pyotp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyotp/pyotp.SlackBuild')
-rw-r--r--python/pyotp/pyotp.SlackBuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/python/pyotp/pyotp.SlackBuild b/python/pyotp/pyotp.SlackBuild
index a8b3154bc0..d1ff8af93c 100644
--- a/python/pyotp/pyotp.SlackBuild
+++ b/python/pyotp/pyotp.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyotp
-# Copyright 2018, 2019 Dominik Drobek <dominik.drobek (at) o2.pl>
+# Copyright 2018-2020 Dominik Drobek <dominik.drobek (at) o2.pl>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyotp
-VERSION=${VERSION:-2.3.0}
+VERSION=${VERSION:-2.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,11 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION