summaryrefslogtreecommitdiffstats
path: root/python/pyperclip/pyperclip.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyperclip/pyperclip.SlackBuild')
-rw-r--r--python/pyperclip/pyperclip.SlackBuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/python/pyperclip/pyperclip.SlackBuild b/python/pyperclip/pyperclip.SlackBuild
index 7e1f0ee474..057abb22e1 100644
--- a/python/pyperclip/pyperclip.SlackBuild
+++ b/python/pyperclip/pyperclip.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyperclip
-# Copyright 2015-2016, 2018 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2016, 2018, 2020 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyperclip
-VERSION=${VERSION:-1.6.4}
-SRCVERSION=${SRCVERSION:-16b1f5b7ece36a08adc5ddec1ef6b1b0aa9de77f}
+VERSION=${VERSION:-1.7.0}
+SRCVERSION=${SRCVERSION:-943372e295764e18ea2069e1c0615ad286089bda}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,12 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true