summaryrefslogtreecommitdiffstats
path: root/python/pysed
diff options
context:
space:
mode:
Diffstat (limited to 'python/pysed')
-rw-r--r--python/pysed/README4
-rw-r--r--python/pysed/doinst.sh3
-rw-r--r--python/pysed/pysed.SlackBuild94
-rw-r--r--python/pysed/pysed.info10
-rw-r--r--python/pysed/slack-desc19
5 files changed, 0 insertions, 130 deletions
diff --git a/python/pysed/README b/python/pysed/README
deleted file mode 100644
index 6373498421..0000000000
--- a/python/pysed/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Pysed is a stream editor, is used to perform basic text
-transformations from a file or from pipeline. It reads text,
-line by line, from a file and replace, insert or print all
-text or specific area.
diff --git a/python/pysed/doinst.sh b/python/pysed/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/python/pysed/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/python/pysed/pysed.SlackBuild b/python/pysed/pysed.SlackBuild
deleted file mode 100644
index fe8667b949..0000000000
--- a/python/pysed/pysed.SlackBuild
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pysed
-
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pysed
-VERSION=${VERSION:-0.7.8}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# avoid install man page over setup.py
-sed -i 's/if "install"/if ""/' setup.py
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# install man page
-mkdir -p $PKG/usr/man/man1
-gzip -9 man/$PRGNAM.1
-install -D -m0644 man/$PRGNAM.1.gz $PKG/usr/man/man1/$PRGNAM.1.gz
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst CHANGELOG LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pysed/pysed.info b/python/pysed/pysed.info
deleted file mode 100644
index c66db8532e..0000000000
--- a/python/pysed/pysed.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pysed"
-VERSION="0.7.8"
-HOMEPAGE="https://github.com/dslackw/pysed"
-DOWNLOAD="https://github.com/dslackw/pysed/archive/v0.7.8.tar.gz"
-MD5SUM="ae638228eb1f101beca70b397e6e4ed7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/pysed/slack-desc b/python/pysed/slack-desc
deleted file mode 100644
index e3dd50873b..0000000000
--- a/python/pysed/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pysed: pysed (sed like utility)
-pysed:
-pysed: Pysed is a stream editor, is used to perform basic text
-pysed: transformations from a file or from pipeline. It reads text,
-pysed: line by line, from a file and replace, insert or print all
-pysed: text or specific area.
-pysed:
-pysed: Homepage: https://github.com/dslackw/pysed
-pysed:
-pysed:
-pysed: