summaryrefslogtreecommitdiffstats
path: root/python/python-certifi/python-certifi.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-certifi/python-certifi.SlackBuild')
-rw-r--r--python/python-certifi/python-certifi.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/python-certifi/python-certifi.SlackBuild b/python/python-certifi/python-certifi.SlackBuild
index 1fa733bbc5..5f8c639a43 100644
--- a/python/python-certifi/python-certifi.SlackBuild
+++ b/python/python-certifi/python-certifi.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-certifi
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2021 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,8 +24,8 @@
PRGNAM=python-certifi
SRCNAM=$(printf $PRGNAM | cut -c8-14)
-VERSION=${VERSION:-2019.3.9}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2020.12.5}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true