summaryrefslogtreecommitdiffstats
path: root/python/python-dateutil/python-dateutil.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-dateutil/python-dateutil.SlackBuild')
-rw-r--r--python/python-dateutil/python-dateutil.SlackBuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/python/python-dateutil/python-dateutil.SlackBuild b/python/python-dateutil/python-dateutil.SlackBuild
index e4751889d2..a11c12c6fc 100644
--- a/python/python-dateutil/python-dateutil.SlackBuild
+++ b/python/python-dateutil/python-dateutil.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-dateutil
-# Copyright 2012 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-dateutil
-VERSION=${VERSION:-2.4.0}
+VERSION=${VERSION:-2.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -55,6 +55,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix end-of-line encoding.
+for i in NEWS PKG-INFO python_dateutil.egg-info/{zip-safe,PKG-INFO}; do
+ cp $i ${i}.new
+ sed -i 's/\r//' ${i}.new
+ touch -r $i ${i}.new
+ mv ${i}.new $i
+done
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \