summaryrefslogtreecommitdiffstats
path: root/python/python-emoji/python-emoji.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-emoji/python-emoji.SlackBuild')
-rw-r--r--python/python-emoji/python-emoji.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/python/python-emoji/python-emoji.SlackBuild b/python/python-emoji/python-emoji.SlackBuild
index 173f4d3870..858e807645 100644
--- a/python/python-emoji/python-emoji.SlackBuild
+++ b/python/python-emoji/python-emoji.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-emoji
-# Copyright 2018-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2018-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,12 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-SRCNAM=emoji
-PRGNAM=python-$SRCNAM
-VERSION=${VERSION:-0.5.4}
+PRGNAM=python-emoji
+VERSION=${VERSION:-1.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+SRCNAM=emoji
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -62,7 +63,7 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
+cd $SRCNAM-v.$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -70,7 +71,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \