summaryrefslogtreecommitdiffstats
path: root/python/python-keyczar/python-keyczar.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-keyczar/python-keyczar.SlackBuild')
-rw-r--r--python/python-keyczar/python-keyczar.SlackBuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/python/python-keyczar/python-keyczar.SlackBuild b/python/python-keyczar/python-keyczar.SlackBuild
index 27d26054e3..7f5789989d 100644
--- a/python/python-keyczar/python-keyczar.SlackBuild
+++ b/python/python-keyczar/python-keyczar.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-keyczar
-# Copyright 2014-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2014-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-keyczar
-VERSION=${VERSION:-0.715}
+VERSION=${VERSION:-0.716}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -55,17 +55,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-rm -rf ${PRGNAM/-/_}.egg-info
-
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog LICENSE PKG-INFO README doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog LICENSE README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install