summaryrefslogtreecommitdiffstats
path: root/python/python-magic/python-magic.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-magic/python-magic.SlackBuild')
-rw-r--r--python/python-magic/python-magic.SlackBuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/python/python-magic/python-magic.SlackBuild b/python/python-magic/python-magic.SlackBuild
index 9479bd48fd..aea733d41b 100644
--- a/python/python-magic/python-magic.SlackBuild
+++ b/python/python-magic/python-magic.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-magic
-# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-magic
-VERSION=${VERSION:-0.4.6}
+VERSION=${VERSION:-0.4.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,10 +50,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -63,6 +63,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README.md > $PKG/usr/doc/$PRGNAM-$VERSION/README.md
+cat $CWD/LICENSE > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install