summaryrefslogtreecommitdiffstats
path: root/python/python-nbxmpp
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-nbxmpp')
-rw-r--r--python/python-nbxmpp/README4
-rw-r--r--python/python-nbxmpp/python-nbxmpp.SlackBuild38
-rw-r--r--python/python-nbxmpp/python-nbxmpp.info12
3 files changed, 14 insertions, 40 deletions
diff --git a/python/python-nbxmpp/README b/python/python-nbxmpp/README
index 2c49f671df..0b019dc8c8 100644
--- a/python/python-nbxmpp/README
+++ b/python/python-nbxmpp/README
@@ -3,7 +3,3 @@ applications to use Jabber/XMPP networks in a non-blocking way.
This library is initialy a fork of xmpppy one, but using
non-blocking sockets.
-
-If you download with wget you should use the --content-disposition option for
-that, or you'll end up with a file named 8 (although the slackbuild checks for
-this file, too).
diff --git a/python/python-nbxmpp/python-nbxmpp.SlackBuild b/python/python-nbxmpp/python-nbxmpp.SlackBuild
index 3692292d8b..5563f6b22d 100644
--- a/python/python-nbxmpp/python-nbxmpp.SlackBuild
+++ b/python/python-nbxmpp/python-nbxmpp.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for python-nbxmpp
-# Copyright 2014-2018 Ruben Schuller
+# Copyright 2014-2022 Ruben Schuller
+# Copyright 2022-2023 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,11 +26,10 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-nbxmpp
-VERSION=${VERSION:-0.6.2}
+VERSION=${VERSION:-3.2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-TARNAM=nbxmpp
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,28 +48,14 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $TARNAM-$VERSION
-tar xvf $CWD/$TARNAM-$VERSION.tar.gz
-cd $TARNAM-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,20 +63,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -r doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cp COPYING $PKG/usr/doc/$PRGNAM-$VERSION
-cp PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cp ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/python-nbxmpp/python-nbxmpp.info b/python/python-nbxmpp/python-nbxmpp.info
index cd327d15ff..856827037d 100644
--- a/python/python-nbxmpp/python-nbxmpp.info
+++ b/python/python-nbxmpp/python-nbxmpp.info
@@ -1,10 +1,10 @@
PRGNAM="python-nbxmpp"
-VERSION="0.6.2"
+VERSION="3.2.5"
HOMEPAGE="https://dev.gajim.org/gajim/python-nbxmpp/"
-DOWNLOAD="https://dev.gajim.org/gajim/python-nbxmpp/uploads/c2db525b46c9c4ac3ada293da7348b7c/nbxmpp-0.6.2.tar.gz"
-MD5SUM="4db4a95b2d53f76afcad3233cd80129b"
+DOWNLOAD="https://dev.gajim.org/gajim/python-nbxmpp/-/archive/3.2.5/python-nbxmpp-3.2.5.tar.gz"
+MD5SUM="c22c9f935b9e093bdb3602145cc49c48"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Ruben Schuller"
-EMAIL="sb@rbn.im"
+REQUIRES="python3-build python3-wheel python-precis-i18n"
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"