summaryrefslogtreecommitdiffstats
path: root/python/python-notify2/python-notify2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-notify2/python-notify2.SlackBuild')
-rw-r--r--python/python-notify2/python-notify2.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/python-notify2/python-notify2.SlackBuild b/python/python-notify2/python-notify2.SlackBuild
index 81fbc72fe7..847f3135da 100644
--- a/python/python-notify2/python-notify2.SlackBuild
+++ b/python/python-notify2/python-notify2.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-notify2
-# Copyright 2015-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2020 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=python-notify2
SRCNAM=$(echo $PRGNAM | cut -c8-14)
VERSION=${VERSION:-0.3.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true