summaryrefslogtreecommitdiffstats
path: root/python/python-oauth2client
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-oauth2client')
-rw-r--r--python/python-oauth2client/README2
-rw-r--r--python/python-oauth2client/python-oauth2client.SlackBuild87
-rw-r--r--python/python-oauth2client/python-oauth2client.info10
-rw-r--r--python/python-oauth2client/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/python/python-oauth2client/README b/python/python-oauth2client/README
deleted file mode 100644
index d3ba4fdb96..0000000000
--- a/python/python-oauth2client/README
+++ /dev/null
@@ -1,2 +0,0 @@
-This is a Python library for accessing resources protected by
-OAuth 2.0.
diff --git a/python/python-oauth2client/python-oauth2client.SlackBuild b/python/python-oauth2client/python-oauth2client.SlackBuild
deleted file mode 100644
index 322669542d..0000000000
--- a/python/python-oauth2client/python-oauth2client.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for "python-oauth2client".
-
-# Copyright 2015-2016 Marcel Saegebarth <marc@mos6581.de>
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-oauth2client
-SRCNAM=oauth2client
-VERSION=${VERSION:-4.0.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/v$VERSION.tar.gz || tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root $PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGELOG.md CONTRIBUTING.md LICENSE README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-oauth2client/python-oauth2client.info b/python/python-oauth2client/python-oauth2client.info
deleted file mode 100644
index 262125f6e8..0000000000
--- a/python/python-oauth2client/python-oauth2client.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-oauth2client"
-VERSION="4.0.0"
-HOMEPAGE="https://github.com/google/oauth2client/"
-DOWNLOAD="https://github.com/google/oauth2client/archive/v4.0.0.tar.gz"
-MD5SUM="c3270b853d66227960b9e04131faf604"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pycrypto"
-MAINTAINER="Marcel Saegebarth"
-EMAIL="marc@mos6581.de"
diff --git a/python/python-oauth2client/slack-desc b/python/python-oauth2client/slack-desc
deleted file mode 100644
index bd2f610411..0000000000
--- a/python/python-oauth2client/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-oauth2client: python-oauth2client (OAuth 2.0 Python library)
-python-oauth2client:
-python-oauth2client: This is a Python library for accessing resources protected by
-python-oauth2client: OAuth 2.0.
-python-oauth2client:
-python-oauth2client: Homepage: https://github.com/google/oauth2client/
-python-oauth2client:
-python-oauth2client:
-python-oauth2client:
-python-oauth2client:
-python-oauth2client: