summaryrefslogtreecommitdiffstats
path: root/python/python-sh/python-sh.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-sh/python-sh.SlackBuild')
-rw-r--r--python/python-sh/python-sh.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/python/python-sh/python-sh.SlackBuild b/python/python-sh/python-sh.SlackBuild
index 031a1c58b8..08c32303e2 100644
--- a/python/python-sh/python-sh.SlackBuild
+++ b/python/python-sh/python-sh.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-sh
-# Copyright 2012-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-sh
VERSION=${VERSION:-1.12.14}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -57,7 +57,7 @@ find -L . \
python setup.py install --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
+if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi