summaryrefslogtreecommitdiffstats
path: root/python/python-stomper/python-stomper.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-stomper/python-stomper.SlackBuild')
-rw-r--r--python/python-stomper/python-stomper.SlackBuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/python/python-stomper/python-stomper.SlackBuild b/python/python-stomper/python-stomper.SlackBuild
index 8a29b5f9d7..04bcdca8f4 100644
--- a/python/python-stomper/python-stomper.SlackBuild
+++ b/python/python-stomper/python-stomper.SlackBuild
@@ -23,7 +23,7 @@
SRCNAM=stomper
PRGNAM=python-$SRCNAM
-VERSION=${VERSION:-0.2.3}
+VERSION=${VERSION:-0.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,20 +64,18 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install