summaryrefslogtreecommitdiffstats
path: root/python/python-stomper
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-stomper')
-rw-r--r--python/python-stomper/python-stomper.SlackBuild16
-rw-r--r--python/python-stomper/python-stomper.info8
-rw-r--r--python/python-stomper/slack-desc2
3 files changed, 12 insertions, 14 deletions
diff --git a/python/python-stomper/python-stomper.SlackBuild b/python/python-stomper/python-stomper.SlackBuild
index 8a29b5f9d7..04bcdca8f4 100644
--- a/python/python-stomper/python-stomper.SlackBuild
+++ b/python/python-stomper/python-stomper.SlackBuild
@@ -23,7 +23,7 @@
SRCNAM=stomper
PRGNAM=python-$SRCNAM
-VERSION=${VERSION:-0.2.3}
+VERSION=${VERSION:-0.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,20 +64,18 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python-stomper/python-stomper.info b/python/python-stomper/python-stomper.info
index 8cbb2fabfd..01c7dfe6c7 100644
--- a/python/python-stomper/python-stomper.info
+++ b/python/python-stomper/python-stomper.info
@@ -1,8 +1,8 @@
PRGNAM="python-stomper"
-VERSION="0.2.3"
-HOMEPAGE="http://code.google.com/p/stomper/"
-DOWNLOAD="http://stomper.googlecode.com/files/stomper-0.2.3.tar.gz"
-MD5SUM="4f64beb3823455d46544c5f10922362a"
+VERSION="0.4.1"
+HOMEPAGE="https://github.com/oisinmulvihill/stomper"
+DOWNLOAD="https://github.com/oisinmulvihill/stomper/archive/0.4.1/stomper-0.4.1.tar.gz"
+MD5SUM="260632d4ebb10e3d30922d9fc59cf2ca"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/python/python-stomper/slack-desc b/python/python-stomper/slack-desc
index c511a1b338..5682fd1755 100644
--- a/python/python-stomper/slack-desc
+++ b/python/python-stomper/slack-desc
@@ -10,7 +10,7 @@ python-stomper: python-stomper (client implementation of the STOMP protocol)
python-stomper:
python-stomper: This is a python client implementation of the STOMP protocol.
python-stomper:
-python-stomper: Homepage: http://code.google.com/p/stomper/
+python-stomper: Homepage: https://github.com/oisinmulvihill/stomper
python-stomper:
python-stomper:
python-stomper: