summaryrefslogtreecommitdiffstats
path: root/python/python-twisted
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-twisted')
-rw-r--r--python/python-twisted/python-twisted.SlackBuild16
-rw-r--r--python/python-twisted/python-twisted.info8
-rw-r--r--python/python-twisted/slack-desc2
3 files changed, 9 insertions, 17 deletions
diff --git a/python/python-twisted/python-twisted.SlackBuild b/python/python-twisted/python-twisted.SlackBuild
index 5e70ceeea6..3b1763df62 100644
--- a/python/python-twisted/python-twisted.SlackBuild
+++ b/python/python-twisted/python-twisted.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-twisted.
-# Copyright 2009 Marco Bonetti <sid77@slackware.it>
+# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,16 +24,14 @@
PRGNAM=python-twisted
SRCNAM=Twisted
-VERSION=${VERSION:-8.2.0}
+VERSION=${VERSION:-11.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -70,19 +68,13 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build || exit 1
+python setup.py build
-python setup.py install --root=$PKG || exit 1
+python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/man
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/slack-desc > $PKG/usr/doc/$PRGNAM-$VERSION/slack-desc
diff --git a/python/python-twisted/python-twisted.info b/python/python-twisted/python-twisted.info
index 7443cd969b..2b527e8ea3 100644
--- a/python/python-twisted/python-twisted.info
+++ b/python/python-twisted/python-twisted.info
@@ -1,10 +1,10 @@
PRGNAM="python-twisted"
-VERSION="8.2.0"
+VERSION="11.0.0"
HOMEPAGE="http://twistedmatrix.com/"
-DOWNLOAD="http://tmrc.mit.edu/mirror/twisted/Twisted/8.2/Twisted-8.2.0.tar.bz2"
-MD5SUM="c85f151999df3ecf04c49a781b4438d2"
+DOWNLOAD="http://pypi.python.org/packages/source/T/Twisted/Twisted-11.0.0.tar.bz2"
+MD5SUM="d7f94a1609a1b8f3b8c8d0146d4cfe54"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Marco Bonetti"
EMAIL="sid77@slackware.it"
-APPROVED="dsomero"
+APPROVED="Niels Horn"
diff --git a/python/python-twisted/slack-desc b/python/python-twisted/slack-desc
index 5d4a1384ee..d41a80ec2f 100644
--- a/python/python-twisted/slack-desc
+++ b/python/python-twisted/slack-desc
@@ -5,7 +5,7 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler----------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
python-twisted: python-twisted (Python networking engine)
python-twisted:
python-twisted: Twisted is an event-driven networking engine written in Python and