summaryrefslogtreecommitdiffstats
path: root/python/python-xlwt
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-xlwt')
-rw-r--r--python/python-xlwt/README6
-rw-r--r--python/python-xlwt/python-xlwt.SlackBuild88
-rw-r--r--python/python-xlwt/python-xlwt.info10
-rw-r--r--python/python-xlwt/slack-desc19
4 files changed, 0 insertions, 123 deletions
diff --git a/python/python-xlwt/README b/python/python-xlwt/README
deleted file mode 100644
index 4d58db130a..0000000000
--- a/python/python-xlwt/README
+++ /dev/null
@@ -1,6 +0,0 @@
-python-xlwt is a library for generating spreadsheet files that are compatible
-with Excel 97/2000/XP/2003, OpenOffice.org Calc, and Gnumeric.
-
-python-xlwt has full support for Unicode. Excel spreadsheets can be generated
-on any platform without needing Excel or a COM server.
-The only requirement is Python 2.3 to 2.7.
diff --git a/python/python-xlwt/python-xlwt.SlackBuild b/python/python-xlwt/python-xlwt.SlackBuild
deleted file mode 100644
index baf84f4f67..0000000000
--- a/python/python-xlwt/python-xlwt.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-xlwt
-
-# Copyright 2013 Mohamed LYAHYAOUI <mlyahyaoui@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-xlwt
-SRCNAM=xlwt
-VERSION=${VERSION:-0.7.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="licences.py README.html"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py build || exit 1
-
-python setup.py install --root $PKG || exit 1
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-xlwt/python-xlwt.info b/python/python-xlwt/python-xlwt.info
deleted file mode 100644
index fb4969c8b9..0000000000
--- a/python/python-xlwt/python-xlwt.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-xlwt"
-VERSION="0.7.5"
-HOMEPAGE="http://www.python-excel.org"
-DOWNLOAD="https://pypi.python.org/packages/source/x/xlwt/xlwt-0.7.5.tar.gz"
-MD5SUM="59cb5efd55319465dfcd25e6a485f03c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Mohamed LYAHYAOUI"
-EMAIL="mlyahyaoui@gmail.com"
diff --git a/python/python-xlwt/slack-desc b/python/python-xlwt/slack-desc
deleted file mode 100644
index fc1d19cb38..0000000000
--- a/python/python-xlwt/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-xlwt: python-xlwt (Python package for generating MS Excel spreadsheets)
-python-xlwt:
-python-xlwt: python-xlwt is a library to create spreadsheet files compatible with
-python-xlwt: MS Excel 97/2000/XP/2003 XLS files, on any platform, with
-python-xlwt: Python 2.3 to 2.7.
-python-xlwt:
-python-xlwt: Homepage: http://www.python-excel.org/
-python-xlwt:
-python-xlwt:
-python-xlwt:
-python-xlwt: