summaryrefslogtreecommitdiffstats
path: root/python/python-zipp/python-zipp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-zipp/python-zipp.SlackBuild')
-rw-r--r--python/python-zipp/python-zipp.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/python/python-zipp/python-zipp.SlackBuild b/python/python-zipp/python-zipp.SlackBuild
index e7c5aef638..4622558c71 100644
--- a/python/python-zipp/python-zipp.SlackBuild
+++ b/python/python-zipp/python-zipp.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-zipp
-# Copyright 2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2019-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-zipp
-VERSION=${VERSION:-0.6.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.2.0}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
SRCNAM=zipp
@@ -71,6 +71,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s,^name =.*$,&\nversion = $VERSION," setup.cfg
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \