summaryrefslogtreecommitdiffstats
path: root/python/python3-babel/python3-babel.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-babel/python3-babel.SlackBuild')
-rw-r--r--python/python3-babel/python3-babel.SlackBuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/python/python3-babel/python3-babel.SlackBuild b/python/python3-babel/python3-babel.SlackBuild
index 9d7fe28dda..afd18c17b3 100644
--- a/python/python3-babel/python3-babel.SlackBuild
+++ b/python/python3-babel/python3-babel.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-babel
#
# Copyright 2013-2018 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
-# Copyright 2019-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2019-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,8 +24,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python3-babel
-VERSION=${VERSION:-2.8.0}
-CLDRVER=${CLDRVER:-36}
+VERSION=${VERSION:-2.9.0}
+CLDRVER=${CLDRVER:-37}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -73,7 +73,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-ln -s $CWD/core.zip cldr/cldr-core-$CLDRVER.zip
+sed -i "s/getiterator/iter/" scripts/import_cldr.py # support Python 3.9
+sed -i "s/elem.getchildren()/list(elem)/" scripts/import_cldr.py # support Python 3.9
+ln -s $CWD/cldr-common-$CLDRVER.0.zip cldr/cldr-core-$CLDRVER.zip
python3 setup.py import_cldr
python3 setup.py install --root=$PKG