summaryrefslogtreecommitdiffstats
path: root/python/python3-babel/python3-babel.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-babel/python3-babel.SlackBuild')
-rw-r--r--python/python3-babel/python3-babel.SlackBuild28
1 files changed, 6 insertions, 22 deletions
diff --git a/python/python3-babel/python3-babel.SlackBuild b/python/python3-babel/python3-babel.SlackBuild
index 75afa25772..bc8f3ad9e8 100644
--- a/python/python3-babel/python3-babel.SlackBuild
+++ b/python/python3-babel/python3-babel.SlackBuild
@@ -2,8 +2,9 @@
# Slackware build script for python3-babel
#
-# Copyright 2013-2018 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
# Copyright 2019-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2013-2018 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +27,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-babel
-VERSION=${VERSION:-2.9.0}
-CLDRVER=${CLDRVER:-37}
+VERSION=${VERSION:-2.14.0}
+CLDRVER=${CLDRVER:-43.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -42,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -54,20 +52,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -85,7 +69,7 @@ find -L . \
sed -i "s/getiterator/iter/" scripts/import_cldr.py # support Python 3.9
sed -i "s/elem.getchildren()/list(elem)/" scripts/import_cldr.py # support Python 3.9
-ln -s $CWD/cldr-common-$CLDRVER.0.zip cldr/cldr-core-$CLDRVER.zip
+ln -s $CWD/cldr-common-$CLDRVER.zip cldr/
python3 setup.py import_cldr
python3 setup.py install --root=$PKG
@@ -94,7 +78,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS CHANGES CONTRIBUTING.md LICENSE README.rst \
+ AUTHORS* CHANGES* CONTRIBUTING* LICENSE* README* \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild