summaryrefslogtreecommitdiffstats
path: root/python/python3-geventhttpclient/python3-geventhttpclient.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-geventhttpclient/python3-geventhttpclient.SlackBuild')
-rw-r--r--python/python3-geventhttpclient/python3-geventhttpclient.SlackBuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/python/python3-geventhttpclient/python3-geventhttpclient.SlackBuild b/python/python3-geventhttpclient/python3-geventhttpclient.SlackBuild
index 88b11f6611..34637d4acd 100644
--- a/python/python3-geventhttpclient/python3-geventhttpclient.SlackBuild
+++ b/python/python3-geventhttpclient/python3-geventhttpclient.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-python3-geventhttpclient
#
-# Copyright 2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2021-2024 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-geventhttpclient
SRCNAM=geventhttpclient
-VERSION=${VERSION:-1.4.5}
+VERSION=${VERSION:-2.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,13 +77,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt LICENSE-MIT $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install