summaryrefslogtreecommitdiffstats
path: root/python/python3-ipython/python3-ipython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-ipython/python3-ipython.SlackBuild')
-rw-r--r--python/python3-ipython/python3-ipython.SlackBuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/python/python3-ipython/python3-ipython.SlackBuild b/python/python3-ipython/python3-ipython.SlackBuild
index b7158286b0..d9388b540e 100644
--- a/python/python3-ipython/python3-ipython.SlackBuild
+++ b/python/python3-ipython/python3-ipython.SlackBuild
@@ -2,7 +2,7 @@
# SlackBuild for python3-ipython
-# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,12 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-SRCNAM=ipython
-PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-7.9.0}
+PRGNAM=python3-ipython
+VERSION=${VERSION:-7.22.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+SRCNAM=ipython
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -57,14 +58,12 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python3 setup.py install --root=$PKG
-rm $PKG/usr/bin/iptest
-rm $PKG/usr/bin/ipython
+rm $PKG/usr/bin/iptest*
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/man/man1
-mv $PKG/usr/share/man/man1/$SRCNAM.1 $PKG/usr/man/man1/${SRCNAM}3.1
+mv $PKG/usr/share/man $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done