summaryrefslogtreecommitdiffstats
path: root/python/python3-json5
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-json5')
-rw-r--r--python/python3-json5/python3-json5.SlackBuild32
-rw-r--r--python/python3-json5/python3-json5.info14
2 files changed, 17 insertions, 29 deletions
diff --git a/python/python3-json5/python3-json5.SlackBuild b/python/python3-json5/python3-json5.SlackBuild
index 443b9d2537..f30ac3058b 100644
--- a/python/python3-json5/python3-json5.SlackBuild
+++ b/python/python3-json5/python3-json5.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for python3-json5
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Erich Ritz, Jenks, Oklahoma, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,12 +26,12 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-json5
-VERSION=${VERSION:-0.9.8}
+VERSION=${VERSION:-0.9.25}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM=json5
+SRCNAM=pyjson5
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -40,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -81,13 +65,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-json5/python3-json5.info b/python/python3-json5/python3-json5.info
index 6221e09945..55dcc9638c 100644
--- a/python/python3-json5/python3-json5.info
+++ b/python/python3-json5/python3-json5.info
@@ -1,10 +1,10 @@
PRGNAM="python3-json5"
-VERSION="0.9.8"
-HOMEPAGE="https://pypi.org/project/json5/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/j/json5/json5-0.9.8.tar.gz"
-MD5SUM="bbd859fbfedd8eecf21d1958dc4a004a"
+VERSION="0.9.25"
+HOMEPAGE="https://github.com/dpranke/pyjson5/"
+DOWNLOAD="https://github.com/dpranke/pyjson5/archive/v0.9.25/pyjson5-0.9.25.tar.gz"
+MD5SUM="59890483e8817b4d5869e751a0e15ac5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+REQUIRES="python3-setuptools-opt"
+MAINTAINER="Erich Ritz"
+EMAIL="erich.public@protonmail.com"