summaryrefslogtreecommitdiffstats
path: root/python/python3-pylint/python3-pylint.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pylint/python3-pylint.SlackBuild')
-rw-r--r--python/python3-pylint/python3-pylint.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/python/python3-pylint/python3-pylint.SlackBuild b/python/python3-pylint/python3-pylint.SlackBuild
index aa44d0e649..e44d5f2ecd 100644
--- a/python/python3-pylint/python3-pylint.SlackBuild
+++ b/python/python3-pylint/python3-pylint.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for python3-pylint
+# Copyright 2022-2023 Dimitris Zlatanidis Orestiada, Greece
# Copyright 2018 Markus Rinne Finland
# All rights reserved.
#
@@ -26,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pylint
SRCNAM=pylint
-VERSION=${VERSION:-2.9.6}
+VERSION=${VERSION:-3.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,10 +81,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m flit_core.wheel
+python3 -m installer -d "$PKG" dist/*.whl
# Rename executables to avoid conflicts with Python 2 version of pylint.
-for executable in epylint pylint pyreverse symilar; do
+for executable in pylint-config pylint pyreverse symilar; do
mv $PKG/usr/bin/${executable}{,3}
done