summaryrefslogtreecommitdiffstats
path: root/python/pytsk/pytsk.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pytsk/pytsk.SlackBuild')
-rw-r--r--python/pytsk/pytsk.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/pytsk/pytsk.SlackBuild b/python/pytsk/pytsk.SlackBuild
index 6401c6a472..6ec9c0a164 100644
--- a/python/pytsk/pytsk.SlackBuild
+++ b/python/pytsk/pytsk.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for pytsk
-# Copyright 2014-2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2014-2023 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated v20190121 March 2019
+# Updated v20230125 July 2023
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pytsk
-VERSION=${VERSION:-20190121}
+VERSION=${VERSION:-20230125}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,7 +82,7 @@ find -L . \
export CC="gcc $SLKCFLAGS $(pkg-config --cflags talloc)"
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true