summaryrefslogtreecommitdiffstats
path: root/python/pyudev/pyudev.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyudev/pyudev.SlackBuild')
-rw-r--r--python/pyudev/pyudev.SlackBuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/python/pyudev/pyudev.SlackBuild b/python/pyudev/pyudev.SlackBuild
index 46a7d008ca..b8564e8eb6 100644
--- a/python/pyudev/pyudev.SlackBuild
+++ b/python/pyudev/pyudev.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyudev
# Copyright 2012 Jon Ware <jon@waremail.net>
-# Copyright 2018 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2018-2019 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pyudev
VERSION=${VERSION:-0.21.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,10 +69,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+# Python 2 support (Default)
+if $(python -c 'import six' 2>/dev/null); then
+ python setup.py install --root=$PKG
+fi
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
+# Python 3 support
+if $(python3 -c 'import six' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi