summaryrefslogtreecommitdiffstats
path: root/python/pyusb/pyusb.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyusb/pyusb.SlackBuild')
-rw-r--r--python/pyusb/pyusb.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/python/pyusb/pyusb.SlackBuild b/python/pyusb/pyusb.SlackBuild
index e8a591e571..69cb9e5d1e 100644
--- a/python/pyusb/pyusb.SlackBuild
+++ b/python/pyusb/pyusb.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for PyUSB
-# Copyright 2014-2019 Kyle Guinn <elyk03@gmail.com>
+# Copyright 2014-2021 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyusb
-VERSION=${VERSION:-1.0.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.1.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -53,6 +53,8 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
+# Can't build the git snapshot. Upstream publishes a modified copy
+# (with version metadata that setup.py needs), see setuptools-scm.
python2 ./setup.py install --root=$PKG
if python3 -c 'import sys' 2>/dev/null; then
rm -rf build