summaryrefslogtreecommitdiffstats
path: root/python/pyusb/pyusb.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyusb/pyusb.SlackBuild')
-rw-r--r--python/pyusb/pyusb.SlackBuild23
1 files changed, 3 insertions, 20 deletions
diff --git a/python/pyusb/pyusb.SlackBuild b/python/pyusb/pyusb.SlackBuild
index 93dfe807cc..c84f256558 100644
--- a/python/pyusb/pyusb.SlackBuild
+++ b/python/pyusb/pyusb.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for PyUSB
-# Copyright 2014 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2014-2016 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyusb
-VERSION=${VERSION:-0.4.3}
+VERSION=${VERSION:-1.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -40,17 +40,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp}
-DOCS="LICENSE README"
-
-if [ $ARCH = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ $ARCH = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ $ARCH = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-else
- SLKCFLAGS="-O2"
-fi
+DOCS="ACKNOWLEDGEMENTS ChangeLog LICENSE README.rst docs/faq.rst docs/tutorial.rst"
set -e
@@ -63,15 +53,8 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
-CFLAGS="$SLKCFLAGS" \
python ./setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Normalize line endings
-sed -i "s/\xd$//g" README
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild