summaryrefslogtreecommitdiffstats
path: root/python/pyusb
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyusb')
-rw-r--r--python/pyusb/README3
-rw-r--r--python/pyusb/pyusb.SlackBuild75
-rw-r--r--python/pyusb/pyusb.info10
-rw-r--r--python/pyusb/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/python/pyusb/README b/python/pyusb/README
new file mode 100644
index 0000000000..c93b48b72b
--- /dev/null
+++ b/python/pyusb/README
@@ -0,0 +1,3 @@
+PyUSB is a native Python module written in C which provides easy USB access
+to Python. The module contains classes and methods to support most USB
+operations.
diff --git a/python/pyusb/pyusb.SlackBuild b/python/pyusb/pyusb.SlackBuild
new file mode 100644
index 0000000000..c7b73e018b
--- /dev/null
+++ b/python/pyusb/pyusb.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for pyusb
+# Written by Kyle Guinn <elyk03@gmail.com>
+
+PRGNAM=pyusb
+VERSION=${VERSION:-0.4.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM-$VERSION
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="PKG-INFO README license.txt"
+
+if [ $ARCH = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ $ARCH = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ $ARCH = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python ./setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Normalize line endings
+sed -i "s/\xd$//g" README
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyusb/pyusb.info b/python/pyusb/pyusb.info
new file mode 100644
index 0000000000..09b9b8432c
--- /dev/null
+++ b/python/pyusb/pyusb.info
@@ -0,0 +1,10 @@
+PRGNAM="pyusb"
+VERSION="0.4.1"
+HOMEPAGE="http://pyusb.berlios.de/"
+DOWNLOAD="http://downloads.sourceforge.net/pyusb/pyusb-0.4.1.tar.gz"
+MD5SUM="9576c3e471e40e021fa44f36712bbd04"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Kyle Guinn"
+EMAIL="elyk03@gmail.com"
+APPROVED="dsomero"
diff --git a/python/pyusb/slack-desc b/python/pyusb/slack-desc
new file mode 100644
index 0000000000..6062d08814
--- /dev/null
+++ b/python/pyusb/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyusb: PyUSB (USB module for Python)
+pyusb:
+pyusb: PyUSB is a native Python module written in C which provides easy USB
+pyusb: access to Python. The module contains classes and methods to
+pyusb: support most USB operations.
+pyusb:
+pyusb:
+pyusb:
+pyusb:
+pyusb:
+pyusb: