summaryrefslogtreecommitdiffstats
path: root/python/pyutil/pyutil.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyutil/pyutil.SlackBuild')
-rw-r--r--python/pyutil/pyutil.SlackBuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/python/pyutil/pyutil.SlackBuild b/python/pyutil/pyutil.SlackBuild
index 94c9ca2b03..7123a6d638 100644
--- a/python/pyutil/pyutil.SlackBuild
+++ b/python/pyutil/pyutil.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for pyutil.
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012 Markus Reichelt, Aachen, DE
+# Copyright 2012-2013 Markus Reichelt, Stolberg (Rhld.), DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@
# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=pyutil
-VERSION=${VERSION:-1.9.3}
+VERSION=${VERSION:-1.9.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,12 +46,19 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
+
set -e
rm -rf $PKG
@@ -62,10 +69,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG