summaryrefslogtreecommitdiffstats
path: root/python/pyzmq/pyzmq.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyzmq/pyzmq.SlackBuild')
-rw-r--r--python/pyzmq/pyzmq.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/python/pyzmq/pyzmq.SlackBuild b/python/pyzmq/pyzmq.SlackBuild
index 85ed893698..34bad90552 100644
--- a/python/pyzmq/pyzmq.SlackBuild
+++ b/python/pyzmq/pyzmq.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyzmq
-VERSION=${VERSION:-14.2.0}
+VERSION=${VERSION:-14.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,14 +68,14 @@ fi
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION