summaryrefslogtreecommitdiffstats
path: root/python/requests-oauthlib/requests-oauthlib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/requests-oauthlib/requests-oauthlib.SlackBuild')
-rw-r--r--python/requests-oauthlib/requests-oauthlib.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/requests-oauthlib/requests-oauthlib.SlackBuild b/python/requests-oauthlib/requests-oauthlib.SlackBuild
index cd03b81261..f915b00dba 100644
--- a/python/requests-oauthlib/requests-oauthlib.SlackBuild
+++ b/python/requests-oauthlib/requests-oauthlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for requests-oauthlib
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=requests-oauthlib
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+#python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true