summaryrefslogtreecommitdiffstats
path: root/python/requests-toolbelt/requests-toolbelt.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/requests-toolbelt/requests-toolbelt.SlackBuild')
-rw-r--r--python/requests-toolbelt/requests-toolbelt.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/requests-toolbelt/requests-toolbelt.SlackBuild b/python/requests-toolbelt/requests-toolbelt.SlackBuild
index c8772b06e1..a044bec034 100644
--- a/python/requests-toolbelt/requests-toolbelt.SlackBuild
+++ b/python/requests-toolbelt/requests-toolbelt.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for requests-toolbelt
-# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2017 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=requests-toolbelt
-VERSION=${VERSION:-0.7.0}
+VERSION=${VERSION:-0.7.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true