summaryrefslogtreecommitdiffstats
path: root/python/ruffus/ruffus.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/ruffus/ruffus.SlackBuild')
-rw-r--r--python/ruffus/ruffus.SlackBuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/python/ruffus/ruffus.SlackBuild b/python/ruffus/ruffus.SlackBuild
index e82481cd28..c826a7e687 100644
--- a/python/ruffus/ruffus.SlackBuild
+++ b/python/ruffus/ruffus.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ruffus
-# Copyright 2018 Rob van Nues
+# Copyright 2018-2019 Rob van Nues
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ruffus
-VERSION=${VERSION:-2.8.1}
+VERSION=${VERSION:-2.8.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+#set which python version to install it for
+PYTHON2=false
+PYTHON3=true
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -69,7 +73,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+if $PYTHON2; then
+ python setup.py install --root=$PKG
+fi
+if $PYTHON3; then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true