summaryrefslogtreecommitdiffstats
path: root/python/simplejson
diff options
context:
space:
mode:
Diffstat (limited to 'python/simplejson')
-rw-r--r--python/simplejson/README3
-rw-r--r--python/simplejson/simplejson.SlackBuild18
-rw-r--r--python/simplejson/simplejson.info6
3 files changed, 16 insertions, 11 deletions
diff --git a/python/simplejson/README b/python/simplejson/README
index d780eb9722..fd00d47fff 100644
--- a/python/simplejson/README
+++ b/python/simplejson/README
@@ -3,4 +3,5 @@ Simplejson is a simple, fast, complete, correct and extensible JSON
pure Python code with no dependencies, but includes an optional C extension for
a serious speed boost.
-Optional documentation can be built if Sphinx and Pygments are installed.
+Optional documentation can be built if Sphinx Pygments are installed. Python3
+bindings can be built if python3 is installed.
diff --git a/python/simplejson/simplejson.SlackBuild b/python/simplejson/simplejson.SlackBuild
index aa9e3dd57e..588fabb55b 100644
--- a/python/simplejson/simplejson.SlackBuild
+++ b/python/simplejson/simplejson.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for simplejson
-# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=simplejson
-VERSION=${VERSION:-3.3.1}
+VERSION=${VERSION:-3.5.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,10 +50,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Make documents if Sphinx and Pygments are installed.
if $(python -c 'import sphinx.pygments_styles' 2>/dev/null); then
@@ -62,7 +62,11 @@ fi
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+if $(python3 -c 'import os' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/simplejson/simplejson.info b/python/simplejson/simplejson.info
index 3861bb58f3..4f6874d49e 100644
--- a/python/simplejson/simplejson.info
+++ b/python/simplejson/simplejson.info
@@ -1,8 +1,8 @@
PRGNAM="simplejson"
-VERSION="3.3.1"
+VERSION="3.5.3"
HOMEPAGE="https://github.com/simplejson/simplejson"
-DOWNLOAD="http://pypi.python.org/packages/source/s/simplejson/simplejson-3.3.1.tar.gz"
-MD5SUM="36eec59b63bb852eaaac724ac8985f74"
+DOWNLOAD="http://pypi.python.org/packages/source/s/simplejson/simplejson-3.5.3.tar.gz"
+MD5SUM="d5f62dfa6b6dea31735d56c858361d48"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""