summaryrefslogtreecommitdiffstats
path: root/python/snuggs/snuggs.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/snuggs/snuggs.SlackBuild')
-rw-r--r--python/snuggs/snuggs.SlackBuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/python/snuggs/snuggs.SlackBuild b/python/snuggs/snuggs.SlackBuild
index 37e474ef39..0e72249f11 100644
--- a/python/snuggs/snuggs.SlackBuild
+++ b/python/snuggs/snuggs.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=snuggs
-VERSION=${VERSION:-1.4.3}
+VERSION=${VERSION:-1.4.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,10 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true