summaryrefslogtreecommitdiffstats
path: root/python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild')
-rw-r--r--python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild b/python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild
index 8184995269..74a5783554 100644
--- a/python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild
+++ b/python/sphinxcontrib-plantuml/sphinxcontrib-plantuml.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sphinxcontrib-plantuml
-# Copyright 2017-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2017-2020 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sphinxcontrib-plantuml
-VERSION=${VERSION:-0.12}
+VERSION=${VERSION:-0.18}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,6 +70,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if python3 -c 'import sys' 2>/dev/null; then
+ python3 ./setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true