summaryrefslogtreecommitdiffstats
path: root/python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml.SlackBuild')
-rw-r--r--python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml.SlackBuild36
1 files changed, 12 insertions, 24 deletions
diff --git a/python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml.SlackBuild b/python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml.SlackBuild
index b8b07f6736..47ba447570 100644
--- a/python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml.SlackBuild
+++ b/python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for sphinxcontrib-serializinghtml
+# Copyright 2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240101 46and2: Updated version, new maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sphinxcontrib-serializinghtml
-VERSION=${VERSION:-1.1.4}
+SRCNAM=sphinxcontrib_serializinghtml
+VERSION=${VERSION:-1.1.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,36 +51,23 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true