summaryrefslogtreecommitdiffstats
path: root/python/thonny/thonny.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/thonny/thonny.SlackBuild')
-rw-r--r--python/thonny/thonny.SlackBuild38
1 files changed, 21 insertions, 17 deletions
diff --git a/python/thonny/thonny.SlackBuild b/python/thonny/thonny.SlackBuild
index 1680cb97aa..d007a27254 100644
--- a/python/thonny/thonny.SlackBuild
+++ b/python/thonny/thonny.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
# Slackware build script for thonny
-# Copyright 2017/8/9 Tim Dickson, Scotland
+# Copyright 2017-21 Tim Dickson, Scotland
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -20,29 +20,33 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#version history
+#version history edited down in size
#2.2.0b4 1 jan 2018. first version for slackbuilds.org
#3.0.5 1 nov 2018. addition of lots of deps.
-#3.0.8 16 nov 2018. version bump.
-#3.1.0 31 jan 2019. version bump.
-#3.1.1 10 Feb 2019. version bump.
-#3.1.2 14 Feb 2019. version bump.
-#3.2.0b1 25 jun 2019. version bump.
-#3.2.0b7 22 Jul 2019. version bump.
-#3.2.0 12 Aug 2019. release version.
-#3.2.1 6 Sep 2019. version bump.
#3.2.2 2 Nov 2019. version bump. added new dep. asttokens
-#3.2.3 4 Nov 2019. version bump.
+#3.2.5 25 Dec 2019. version bump. added extra dep. send2trash
#add optional dep on pygame with python3 support. common for python learners
#which thonny is targetted at.
-#note. get download link from https://pypi.org/project/thonny/#files
+#3.2.6 06 Jan 2020. version bump. also added optional dep of esptool
+#3.2.7 23 Jan 2020. version bump. added dep of python-distro
+#3.3.3 27 Jan 2021. version bump.
+#build2 10 Feb 2021. move install location to allow a plugin to work.
+#thanks to chrisw. changed build arch as install is arch specific now.
+#3.3.6 25 Mar 2021. version bump.
+#note. get download link from https://pypi.org/project/thonny/#files
PRGNAM=thonny
-VERSION=${VERSION:-3.2.3}
+VERSION=${VERSION:-3.3.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-ARCH=noarch
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
@@ -57,6 +61,8 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar -xzf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+#patch to remove mypy warning. thanks to chrisw
+sed -i -e 's/logger.warning("MyPy: " + "".join(err_lines))/pass/' thonny/plugins/mypy/__init__.py
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -64,9 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-install -D -m0755 $CWD/$PRGNAM.sh $PKG/usr/bin/$PRGNAM
-mkdir -p $PKG/opt/$PRGNAM
-cp -r $PRGNAM $PKG/opt/
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/share/applications
cp -a packaging/linux/org.thonny.Thonny.desktop $PKG/usr/share/applications/$PRGNAM.desktop
mkdir -p $PKG/usr/share/pixmaps