summaryrefslogtreecommitdiffstats
path: root/python/thonny/thonny.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/thonny/thonny.SlackBuild')
-rw-r--r--python/thonny/thonny.SlackBuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/python/thonny/thonny.SlackBuild b/python/thonny/thonny.SlackBuild
index 8799c6e590..4f7aa038a7 100644
--- a/python/thonny/thonny.SlackBuild
+++ b/python/thonny/thonny.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
# Slackware build script for thonny
-# Copyright 2017-21 Tim Dickson, Scotland
+# Copyright 2017-23 Tim Dickson, Scotland
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -20,25 +20,19 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#version history edited down in size
+#version history -edited down in size to first and last 4 updates
#2.2.0b4 1 jan 2018. first version for slackbuilds.org
-#3.0.5 1 nov 2018. addition of lots of deps.
-#3.2.2 2 Nov 2019. version bump. added new dep. asttokens
-#3.2.5 25 Dec 2019. version bump. added extra dep. send2trash
-#add optional dep on pygame with python3 support. common for python learners
-#which thonny is targetted at.
-#3.2.6 06 Jan 2020. version bump. also added optional dep of esptool
-#3.2.7 23 Jan 2020. version bump. added dep of python-distro
-#3.3.3 27 Jan 2021. version bump.
-#build2 10 Feb 2021. move install location to allow a plugin to work.
-#thanks to chrisw. changed build arch as install is arch specific now.
-#3.3.6 25 Mar 2021. version bump.
+#editted out :-)
+#4.1.2 16 Aug 2023. version bump
+#4.1.3 5 Oct 2023. version bump
+#4.1.3 build2 27 Oct 2023. change deps.
+#4.1.4 8 Dec 2023. version bump
#note. get download link from https://pypi.org/project/thonny/#files
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=thonny
-VERSION=${VERSION:-3.3.6}
+VERSION=${VERSION:-4.1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,9 +77,11 @@ find -L . \
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/share/applications
cp -a packaging/linux/org.thonny.Thonny.desktop $PKG/usr/share/applications/$PRGNAM.desktop
-mkdir -p $PKG/usr/share/pixmaps
-cp -a packaging/icons/$PRGNAM-*.png $PKG/usr/share/pixmaps/
-cp -a packaging/icons/$PRGNAM-128x128.png $PKG/usr/share/pixmaps/$PRGNAM.png
+mkdir -p $PKG/usr/share/icons/hicolor/{16x16,22x22,32x32,48x48,64x64,128x128,192x192,256x256}/apps
+for i in `ls packaging/icons/$PRGNAM-*x*.png`; do
+ IDIR=`echo $i|awk -F"-" '{print $2}'|awk -F"." '{print $1}'`
+ cp -a $i $PKG/usr/share/icons/hicolor/$IDIR/apps/$PRGNAM.png
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
for i in CREDITS.rst README.rst CHANGELOG.rst LICENSE.txt; do
cp $i $PKG/usr/doc/$PRGNAM-$VERSION