summaryrefslogtreecommitdiffstats
path: root/python/typing-extensions/typing-extensions.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/typing-extensions/typing-extensions.SlackBuild')
-rw-r--r--python/typing-extensions/typing-extensions.SlackBuild33
1 files changed, 23 insertions, 10 deletions
diff --git a/python/typing-extensions/typing-extensions.SlackBuild b/python/typing-extensions/typing-extensions.SlackBuild
index 88335bc5be..b10423fe6f 100644
--- a/python/typing-extensions/typing-extensions.SlackBuild
+++ b/python/typing-extensions/typing-extensions.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=typing-extensions
PKGNAM=typing_extensions
-VERSION=${VERSION:-3.7.4.3}
+VERSION=${VERSION:-3.7.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,7 +39,7 @@ if [ -z "$ARCH" ]; then
fi
CWD=$(pwd)
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -58,14 +58,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
-fi
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+set -- ./*
+
+mkdir -p build-py2 build-py3
+cp -r -- "$@" build-py2
+cp -r -- "$@" build-py3
+
+(
+ cd build-py2
+ # Python 2.7 will be dropped in the future.
+ if python2 -c 'import sys' 2>/dev/null; then
+ python2 setup.py install --root=$PKG
+ fi
+)
+
+(
+ cd build-py3
+ # Replacement of python-2.x Python3.x check presence and build if found.
+ if python3 -c 'import sys' 2>/dev/null; then
+ python3 setup.py install --root=$PKG
+ fi
+)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION