summaryrefslogtreecommitdiffstats
path: root/python/werkzeug/werkzeug.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/werkzeug/werkzeug.SlackBuild')
-rw-r--r--python/werkzeug/werkzeug.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/python/werkzeug/werkzeug.SlackBuild b/python/werkzeug/werkzeug.SlackBuild
index a80c334d62..622bc4e4a0 100644
--- a/python/werkzeug/werkzeug.SlackBuild
+++ b/python/werkzeug/werkzeug.SlackBuild
@@ -2,8 +2,8 @@
# Slackware build script for werkzeug
-# Copyright 2018 Dominik Drobek <dominik.drobek (at) o2.pl>
# Copyright 2013 Mohamed LYAHYAOUI <mlyahyaoui@gmail.com>
+# Copyright 2018-2020 Dominik Drobek <dominik.drobek (at) o2.pl>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=werkzeug
SRCNAM=Werkzeug
-VERSION=${VERSION:-0.14.1}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,15 +71,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build
+python setup.py install --root=$PKG
-python setup.py install --root $PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CHANGES.rst LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst LICENSE.rst PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install